
Photo retouching with Free Software



What is Free Software?

● It's more than just “free” 
(i.e. it's not just about the 
money)

● It's about giving you a 
hand in the process

● You are free to help guide 
the software
– File bugs
– Write code
– Write documentation
– Help others



The GIMP

● What the GIMP is
– A capable modern digital 

image editing application

● What the GIMP is not
– A “Photoshop Killer”
– Suitable (by itself) for 

commercial print 
separation production

– Suitable for use in a fully 
colour managed work 
flow (Yet!)

– Capable of editing deep 
colour images

(Yes, it is a silly name.)

GNU Image Manipulation Package

GNU's Not Unix

(No, they won't change it.)



Getting the GIMP
● From the Internet

– Windows
● http://GIMP-win.sourceforge.net/
● Stable
● GTK+GIMP(+GIMP Help+GIMP Animation)

– OSX
● http://www.GIMP.org/macintosh/

– Linux(/FreeBSD)
● Probably already installed (otherwise depends on distro)

● From the CDs I've brought with me
– Pop it in when you're in Windows and follow the prompts
– Pop it in when your computer starts try Ubuntu Linux



Installing the GIMP on Windows

● Two set-up files minimum
– First: gtk-setup

● Double click then Next-Next-Next...
– Second: GIMP

● Double click then Next-Next-Next...
● Optional

– On-line Help files
● Double click then Next-Next-Next...

– Animation
● Double click then Next-Next-Next...



First run of the GIMP

● Next
● Next
● Next
● Wait



Welcome to the GIMP

● 2 windows
– Each window made up of 

panes
● which can be detached...
● ...re-attached...
● ...shuffled...
● ...turned into tabs...
● ...as you see fit.

– it's your workspace and 
work flow You decide.

● The image loads in a 
separate window



The Toolbox

● Similar tools to any other 
photo editing application
– Selection Tools
– Measure and move
– Crop, Rotate, Skew
– Text
– Fill/Paint
– Retouching tools
– Colour Well
– Brush Status



More Dialogues and Help
● File>Dialogues

– Dock or not as you see fit
● Help>Help

– Only works if you 
installed the optional 
Help package

● Right Click gets you 
(almost) anywhere quickly

● Alt, Ctrl and Shift keys 
often have special 
functions



...and so ends the tour of the GIMP

● Because everything else I'm about to talk about should be 
possible in almost any basic image editing program with a 
little modification

● Many Photoshop web tutorials can be adapted for the 
GIMP with a little imagination



Landscape



The starting images
● Each image taken on a 

tripod
– Minimum movement 

makes blending easier
● ISO160

– Lowest ISO speed I have 
to reduce CCD noise

● Exposed for 1/1300sec
● Average metering
● F (aperture) varied for each 

shot

More data in the EXIF if you want it



Selecting the base images
● Image 1

– Well exposed sky
– Plenty of cloud detail
– Ground poorly exposed

● Image 2
– Sky blown out
– Ground well exposed
– Camera was not completely 

overwhelmed by the sun



Destructive vs Non-Destructive editing

● Wherever possible, don't touch the original image!
– Why?

● Because you may change your mind about some of your edits
– How?

● Use “Layers” and “Masks” wherever possible.
● If you absolutely need to work on the original pixels, make a 

layer copy of your image and work on that
● What's a Layer?

– Imagine painting on cellophane sheets laid over top of your 
image

● What's a Mask?
– Imagine cutting holes in the sheets to allow lower sheets to 

show through



Lets begin

● Step one
– Copy the second (ground exposed) image on to a layer over 

the first (sky exposed) image
– Add a mask
– Use a black-white gradient fill on the mask to let the lower 

layer show through
● You could carefully paint the mask around the trees

– I'm lazy
– Black areas of the mask show the layer(s) underneath
– White areas keep the associated layers image



Landscape cont...
● Step 2

– Duplicate the 2nd layer
– Change the Blend Mode to Screen

● This is a quick'n'dirty way to lighten an image
● Step 3

– Dodge and Burn the clouds for dramatic effect
● 2 ways to do this

– Dodge+Burn Tool
● But you would have to merge the lower layers (destructive)

– Make a new layer, fill with 50% gray, set blend mode to “Soft 
Light”. Paint with black or white to dodge or burn.

● But this method lacks the ability to touch just highlights mid 
tones or shadows

● Use a feathered brush. Hard edges are obvious and 
distracting.



Landscape cont...

● Step 4
– New Layer. Blend mode set to Colour
– Get a nice blue
– Paint the sky
– Dial back the layers opacity to the point where the effect no 

longer looks awful
● Step 5 (Optional, I decided I liked it)

– New Layer
– Radial fill, white to transparent, from centre of clouds to 

blow out the middle



Landscape cont...

● Step 6
– Fake vignetting

● Focuses the eye towards the centre
– New layer
– Oval selection tool
– Invert selection
– Feather
– Fill with black
– Dial back layers opacity



Landscape cont...

● Step 7
– Add a “Dreamy” blur
– Copy Visible image
– New layer
– Paste
– Gaussian blur
– Change layer blend mode to something that works

● Soft light seems nice
– Dial back the layers opacity



Nearly there
● Composition isn't quite right
● Step 8

– Copy visible
– Create new image
– Paste
– Rectangular select flat grass
– Feather
– Copy
– Scale
– Anchor
– Crop

● Step 9
– Duplicate layer add Retinex filter and dial back opacity









Portrait work



Common Tasks - Lightness
● Lightening an image

– Duplicate layer, set to screen (Quick, Dirty, Imprecise)
– Levels (Quick)
– Curves (Relatively Quick, more flexible)
– Convert (Decompose) to LAB

● Adjust Lightness Layer/Channel
– Advantage – doesn't alter colour saturation

● Also a good time to sharpen
– Won't amplify colour noise

● LAB colour space is larger than RGB, so no loss of 
information

– Work with HSL (Hue Saturation Lightness)
● Tools>Colour>Hue-Saturation

– Advantage – Again, shouldn't affect hue or saturation
– Disadvantage – Can shift histogram around, but probably won't be 

able to get a good spread
● Decompose to HSL/HSV

– Similar to LAB decompose – just work on the L/V layer



Common tasks – Selecting areas
● Selecting areas

– Lasso (Imprecise)
– Colour selector

● Good for areas of uniform colour, e.g. skys
– Select Shapes from image (Photoshop Magnet)

● Quick and Reasonably Good when there is a strong contrast 
between desired area and background

– Paths to selection
● Good for smooth objects with few jagged edges

– The more edges you have to deal with, the longer it will take
– To close the path, hold Ctrl and select the last node

– Quick mask
● Paint the area you want

– Channels
● Look for a channel with high contrast between area you want 

and don't want
– Copy it, alter it and use it as a selection mask
– Can be great for selecting hair outline



Common tasks – Removing objects

● Clone
– Use ctrl to select area to clone from

● Remember to switch to the right layer first
● Then switch to the layer you want to work on

– Clone away
● Fill the area

– Looks very fake
● What's missing?
● Noise! We expect noise.

– Add some, then blur it to match the noise in the real image
– Probably need to clone at the edges to blend areas



Common tasks – Skin work
● Smoothing skin

– Removes wrinkles and small skin blemishes
– Duplicate layer
– Blur it

● Not too much, or the skin will look plastic
– Add a (white) layer mask

● Paint areas of interest back in
– Eyes
– Eyebrows
– Ears
– Mouth
– Nose
– Outline
– Hair 

● Reduce shiny areas
– New layer
– Set blend mode to darken
– Clone with a low opacity from a layer below



Common Tasks – Eyes and teeth
● Lighten and Whiten

– Duplicate layer and screen
– Add a (black) mask
– Paint areas that need to be lightened/whitened
– Dial back layer opacity to avoid glowing eyes/teeth

● Still too yellow
– Change blend mode to normal
– Tools>Colour>Hue-Saturation
– Lighten
– Lower saturation
– Adjust opacity to suit

● Iris
– Copy the eyes to a new layer above whitening layer
– Use a mask to just select the iris & pupil
– Use levels (or HSL/Curves/Brightness+Contrast) to up 

colour saturation and contrast.



Common Tasks – Eyes cont

● With female models it's quite common to enlarge the eyes 
slightly
– The IWarp filter is ideal for this

● Filters>Distorts>IWarp
● (Edit>Liquefy in Photoshop)

– IWarp can also be used to slim noses
– Or distort things for fun



Common Tasks – Convert to B/W

● Many methods to generate a B/W version
● Each can give different results

– Convert to grayscale
– Layers>Colours>Desaturate
– Decompose

● To RGB Channels
– Red Green and Blue Channels will all look different

● To LAB
– Take the Lightness Channel

● To CMYK
– Invert the blacK layer

● To YCrB
– Y carries Luminance

– Channel Mixer



Common Tasks - Sepia

● Tools>Colour>Colourise
– Adjust Hue Saturation 

and Lightness to suit
● Quick

● Make a B/W image
– New Layer
– Fill with a brown
– Change blend mode to 

colour
● You can consistently apply 

the same tone to other 
pictures



Colour calibrate your monitor
● Why?

– So What you see is (nearly) what you get
● There will always be some difference

● Set your screen to 6500K
– Closest temperature to white paper in sunlight

● If using a CRT
– Set to 6500K (Whites are more yellow vs blue)

● Make a “coarse” colour profile
– Adobe Gamma Wizard
– Coral Colour Profile
– nVidia Display wizard

● If using an LCD
– Most Cold cathode tubes = ~9300k

● Try and coarse colour profile it
● Beware your viewing angle
● You'll probably have to lump it (in my limited experience)



A word on colour spaces
● sRGB

– Smaller gamut
● Smaller jumps between 

displayable colours
● Smoother “jumps” = 

smoother tones (e.g. 
skin)

– Most monitors work in 
sRGB colour space

– Most consumer (read 
inkjet) printers too

– and common commercial 
printers 
(TruPrint/Photobox)

● AdobeRGB(1998)
– Wider gamut

● Can display a wider 
“variety” of colours

● But takes bigger 
“jumps” between 
colours to do so

● Richer Greens and 
Cyans/Blues

– Not viewable on most 
monitors

– Better matches gamut of 
commercial CMYK 
separation printing



Choose your colour space by work 
flow and final “print” method

● I intend to print my 
pictures:
– at home
– via an on-line service
–  display my pictures on 

the web
– display my pictures on a 

UK TV
● Ideally capture, work on 

and save in sRGB

● My editor/printer has 
requested AdobeRGB

● As far as you can, capture 
work and save in 
AdobeRGB

● Use PhotoshopCS2 to 
simulate AdobeRGB on 
your sRGB monitor

● If you have a nice 
AdobeRGB capable 
monitor use it



Final Colour space notes
● Actually, the ideal capture step is in RAW

– You can then decide afterwards if you want to go sRGB or 
AdobeRGB

● Converting between AdobeRGB and sRGB considered 
harmful!
– You get all the disadvantages of AdobeRGB

● Large jumps between colour values
– You get all the disadvantages of sRGB

● Smaller gamut
– And none of the advantages of either!

● Realistically, to work in a fully colour space managed work flow 
you'll need PhotoshopCS2
– GIMP has only limited colour management at this time, but is 

due to improve
– For most here though, I just don't expect that to matter



High Dynamic Range
● Our eyes are most sensitive to changes in brightness 

(contrast)
● Can discern changes over a massive scale

– e.g. sitting in doors you can see everything lit by artificial 
light, and through a window, natural light outside. A 
photograph would likely over or under expose one or more 
aspects

● Unfortunately our computer monitors can't display the same 
range
– For the most part cameras can't capture it either

● RAW does better, but traditional RAW processing forces you 
to toss information out

● So we get images with blown out areas that our eyes could 
have coped with



HDR and Tone Mapping

● HDR images can be created straight from RAW files
– Or assembled from multiple exposures

● But our monitors can't display this extra information, so we 
still can't see it

● Enter “Tone Mapping”
– By using colour and local contrast tricks it is possible to 

fake HDR effect
● Photomatix (~£99) and Photoshop CS2 (~£400) can do it
● Qtpfsgui can do it for free

– http://qtpfsgui.sourceforge.net/
– Available for Windows, but without a friendly installer



Tone mapped examples

● Author: Dean S. Pemberton
● HDR image.
● Canon 350D
● f/8, ISO100
● 18mm
● 8 Exposures
● 30" 20" 12" 5" 3" 1" 1/4" 1/20"



Thank you for listening

● GIMP resources
– Get it

● http://www.GIMP.org/
● http://GIMP-win.sourceforge.net/

– GIMP Tutorials
● http://www.GIMP.org/tutorials/
● http://gug.sunsite.dk/?page=tutorials
● http://www.GIMPtalk.com/
● http://www.pixel2life.com/tutorials/GIMP/All/
● http://GIMPology.com/
● http://GIMPguru.org/

– Photoshop Tutorials
● http://www.photoshoptv.com/
● http://www.photoshopkillertips.com/
● http://www.photoshopquicktips.com/



...resources continued

● Colour Calibration
– http://en.wikipedia.org/wiki/Color_calibration
– http://www.normankoren.com/makingfineprints1A.html

● sRGB vs AdobeRGB
– http://www.cambridgeincolour.com/tutorials/sRGB-AdobeRGB1998.htm
– http://www.smugmug.com/help/srgb-versus-adobe-rgb-1998
– http://www.nulab.com.au/newsletter/november2004/sRGBViaAdobe.htm

● HDR
– http://en.wikipedia.org/wiki/High_dynamic_range_imaging
– http://qtpfsgui.sourceforge.net/


